https://gtacknowledge.extremenetworks.com/articles/How_To/000034045/?l=en_US&fs=RelatedArticle
VOSS (VSP)
The following CLI commands were used to gather information from the VOSS switches in the network:
terminal more disable
# CONFIGURATION, SERVERS, LICENSE and TECH
show running-config
show boot config flags
show ntp
show ntp server
show ntp statistics
show license
show web-server
show sys setting
show tech
# SNMP
show snmplog
show snmp-server
show snmp-server community
show snmp-server host
# RADIUS
show radius
show radius snmp
show radius reachability
show radius-server
show radius-server statistics
# KHI
show khi performance cpu
show khi performance memory
show khi performance buffer-pool
# QOS and RESOURCES
show filter acl statistics
show filter acl statistics all
show sys mgid-usage
show sys stats ipmc-threshold-exceeded-cnt
show qos cosq-stats cpu-port
show qos cosq-stats interface
show qos 802.1p-override
show qos egressmap
show qos ingressmap
show qos queue-profile
show qos rate-limiting interface gigabitEthernet
show qos shaper interface gigabitEthernet
# HARDWARE and SOFTWARE
show software
show software detail
show sys-info card
show sys-info temperature
show sys-info fan
show sys-info power
show sys-info uboot
show sys software
show sys power
show sys power power-supply
show alarm database
show alarm statistics
# TOPOLOGY
show autotopology nmm-table
# LLDP
show lldp
show lldp local-sys-data
show lldp port
show lldp neighbor
show lldp stats
# IPv4 ARP and ROUTE
show ip interface vrfids 0-512
show ip arp vrfids 0-512
show ip vrf
show ip vrf max-routes
show ip route count-summary vrfids 0-512
show ip route vrfids 0-512
show ip route alternative vrfids 0-512
show interfaces gigabitethernet vrfs
show interfaces vlan vrfs
# IPv6 INFO
show ipv6 address interface
# VRRP
show ip vrrp vrfids 0-512
show ip vrrp interface vrfids 0-512
show ip vrrp address vrfids 0-512
# RSMLT
show ip rsmlt vrfids 0-512
show ip rsmlt edge-support
# MSTP
show spanning-tree mstp config
show spanning-tree mstp status
show spanning-tree mstp msti config
show spanning-tree mstp statistics
# SLPP
show slpp
show slpp interface gigabitEthernet
# INTERFACES
show interfaces gigabitEthernet channelize
show interfaces gigabitEthernet private-vlan
show interfaces gigabitEthernet rate-limit
show interfaces gigabitEthernet shape
show interfaces gigabitEthernet high-secure
show interfaces gigabitEthernet statistics
show interfaces gigabitEthernet statistics dhcp-relay
show interfaces gigabitEthernet statistics lacp
show interfaces gigabitEthernet statistics rate-limiting
show interfaces gigabitEthernet statistics rmon
show interfaces gigabitEthernet statistics verbose
show interfaces gigabitEthernet error
show interfaces gigabitEthernet error verbose
show interfaces gigabitEthernet error collision
# VLAN
show vlan name
show port vlans
# MLT, SMLT and IST
show mlt
show mlt error main
show mlt stats
show smlt mlt
show virtual-ist
show virtual-ist stat
# LACP
show lacp
show lacp interface
# VLACP
show vlacp
show vlacp interface gigabitethernet
# RIP
show ip rip vrfids 0-512
# OSPF
show ip ospf vrfids 0-512
show ip ospf area vrfids 0-512
show ip ospf authentication interface vlan
show ip ospf ifstats vrfids 0-512
show ip ospf interface vrfids 0-512
show ip ospf neighbor vrfids 0-512
show ip ospf stats vrfids 0-512
# BGP
show ip bgp aggregates vrfids 0-512
show ip bgp conf vrfids 0-512
show ip bgp neighbors vrfids 0-512
show ip bgp networks vrfids 0-512
show ip bgp peer-group vrfids 0-512
show ip bgp redistributed-routes vrfids 0-512
show ip bgp route vrfids 0-512
show ip bgp stats vrfids 0-512
show ip bgp summary vrfids 0-512
# MROUTE
show ip mroute hw-resource-usage vrfids 0-512
show ip mroute interface vrfids 0-512
show ip mroute route vrfids 0-512
show ip mroute next-hop vrfids 0-512
show ip mroute static-source-group
# IGMP
show ip igmp interface vrfids 0-512
show ip igmp group vrfids 0-512
show ip igmp cache vrfids 0-512
show ip igmp sender vrfids 0-512
show ip igmp snooping vrfids 0-512
show ip igmp snoop-trace vrfids 0-512
show ip igmp static vrfids 0-512
show ip igmp stream-limit interface vrfids 0-512
show ip igmp sys vrfids 0-512
# SPBM
show spbm
show isis
show isis area
show isis manual-area
show isis system-id
show isis net
show isis interface
show isis adjacencies
show isis statistics
show isis spb-mcast-summary
show isis logical-interface
show isis int-l1-cntl-pkts
# SPBm
show isis spbm
show isis spbm nick-name
show isis spbm unicast-tree 4051
show isis spbm unicast-tree 4052
show isis spbm ip-unicast-fib
show isis spbm i-sid all
show isis spbm unicast-fib
show isis spbm unicast-fib summary
show isis spbm multicast-fib summary
show isis spbm ip-multicast-route
show isis spbm ip-multicast-route group 239.255.255.250
show cfm maintenance-endpoint
show vlan i-sid
show ip ipvpn vrfids 1-512
# FA
show fa
show fa interface
# PLUGGABLE
show pluggable-optical-modules basic
show pluggable-optical-modules detail
# DIRECTORY
dir /intflash -l -r
#END
terminal more enable terminal more enable
###############################################################
BOSS (ERS)
The following CLI commands were used to gather information from the BOSS stacks:
terminal length 0
terminal width 132
# CONFIGURATION, SERVERS, LICENSE and TECH
show cpu-utilization
show running-config
show sntp
show logging config
show autosave
show stack health
show stack forced-mode
show ssh global
show license all
show tech
# SNMP
show snmp-server
show snmp-server host
# RADIUS
show radius reachability
show radius use-management-ip
show radius-server
# KHI
show cpu-utilization
show environmental
# QOS and RESOURCES
show qos acl-assign
show qos diag
show qos queue-set
show qos queue-set-assignment
show qos queue-statistics
show qos queue-statistics non-zero
show qos egressmap
show qos ingressmap
show qos classifier
show qos classifier-block
show qos action all
show qos agent
show qos if-group
show qos if-assign
show qos traffic-profile
show qos traffic-profile interface
show qos capability shaper
show qos if-queue-shaper
show qos if-shaper
show qos capability meter
show qos policy
show qos port ALL
show rate-limit
# HARDWARE and SOFTWARE
show memory-utilization
show nvram block
show port-mirroring
show boot image
show interfaces gbic-info
show flash history
show flash history unit 2
show flash history unit 3
show flash history unit 4
show flash history unit 5
show flash history unit 6
show flash history unit 7
show flash history unit 8
# STACKING INFO
show stack-info
show stack-info uptime
show stack-monitor
show stack auto-unit-replacement-image
show stack port-statistics
show stack port-statistics unit 2
show stack port-statistics unit 3
show stack port-statistics unit 4
show stack port-statistics unit 5
show stack port-statistics unit 6
show stack port-statistics unit 7
show stack port-statistics unit 8
# TOPOLOGY
show autotopology nmm-table
# LLDP
show lldp
show lldp local-sys-data
show lldp mgmt-sys-data
show lldp neighbor
show lldp stats
# IP
show ip
show ip routing
show route-map
show ipmgr
show arp
show arp-table
show ip ipfix
show brouter
show ip directed-broadcast
show ip mgmt route
show ip arp-proxy interface
show ip arp-inspection
# MLT, SMLT, SLT and IST
show mlt
# DHCP
show ip dhcp-relay fwd-path
show ip dhcp-relay counters
show vlan dhcp-relay
show ip dhcp client lease
# IGMP
show ip igmp interface
show ip igmp group
show ip igmp snooping
# RIP
show ip rip
# OSPF
show ip ospf
# LACP
show lacp system
show lacp stats
show lacp port
show lacp stats
# VLACP
show vlacp
show vlacp interface
# VLAN
show vlan ip
show auto-pvid
show vlan configcontrol
show vlan summary
show vlan interface vids
show vlan interface info
show mac-address-table
# INTERFACES
show port-statistics
# STP
show spanning-tree mode
show spanning-tree config
show spanning-tree port-mode
show spanning-tree port
show spanning-tree vlans
# MSTP
show spanning-tree mstp config
show spanning-tree mstp status
show spanning-tree mstp statistics
show spanning-tree mstp port role
# BPDU
show spanning-tree bpdu-filtering
# SLPP
show slpp-guard
# POE
show poe-main-status
show poe-main-status unit 1
show poe-main-status unit 2
show poe-main-status unit 3
show poe-main-status unit 4
show poe-main-status unit 5
show poe-main-status unit 6
show poe-main-status unit 7
show poe-main-status unit 8
# END
terminal length 20
Snippet from R1 acting as ASBR with static route towards external router showing the redistribution of the external route into OSPF.
R1
ip route 3.3.3.3 255.255.255.255 10.10.10.2 weight 1
ip route 3.3.3.3 255.255.255.255 10.10.10.2 enable
ip prefix-list StaticOSPFRedistribute 3.3.3.3/32 ge 32 le 32
route-map “OSPFStatic” 1
enable
match network “StaticOSPFRedistribute”
exit
router ospf
as-boundary-router enable
redistribute static route-map “OSPFStatic”
redistribute static metric 10
redistribute static metric-type type1
redistribute static enable
exit
#WARNING: Routes will not be injected until apply command is issued after enable command
ip ospf apply redistribute static
show ip route
show ip ospf redistribute
show ip prefix-list
show route-map
show route-map detail
There is an inconsistency between CLI and EDM in release 5.9 which results in an EDM error Wrong Value when select 802.3at and 32w on a port.
See attached solution note from Avaya support webpage.
https://support.avaya.com/ext/index?page=content&id=SOLN320951
This issue was fixed in release 5.10. Upgrading the switch to the latest release should eliminate this error. Upgraded switch to 5.12.3 release. The option in EDM for 802.3at has been removed.
It is possible to set 32w of power on a port configured as 802.3af on the Avaya ERS 4850 as a PWR+ switch supports 802.3at.
If still have issues negotiating power with a PD then try to use LLDP on the PSE and PD.
Below are the power related commands that can be enabled.
Switch(config)Interface ethernet 1/13
Switch(config-if)#lldp status txAndRx config-notification
Switch(config-if)#lldp tx-tlv port 1/13 dot3 mdi-power-support
Switch(config-if)#lldp tx-tlv port 1/13 med med-capabilities
Switch(config-if)#lldp tx-tlv port 1/13 med extendedPSE
The AP must have LLDP enabled also so they can exchange LLDPDUs. This note relates to the experience found providing the power demanded for an Aerohive 650 Access Point on an Avaya ERS 4850GTS-PWR+ switch.
On the ERS switch use the show autotopology nmm-table command to display local and remote ports of switch connections. Here we can see discovery information for a switch which is SMLT connected with a core of two Passport 8610 switches from the perspective of the ERS5530-24TFD switch.
ERS 4900, ERS 5900
Base Unit Select switch – used to designate the base unit in a stack. When set DOWN, this unit acts as the Base Unit for the stack. Only one switch in the stack must have the Base Unit Select in base position.
ERS 3500, ERS 3600, ERS 4800
Base Unit Select Switch – used to designate the Base Unit in a stack. When set to the RIGHT position, this unit acts as the Base Unit for the stack.
If have problem connecting to EDM with ERS switch after upgrade of the agent code or to browser then try recreating the SSL certificate:
ssl certificate
ssl reset
show ssl
Note: Tested with Firefox 65 (64 bit) and Internet Explorer 11 against ERS 5.3.9.011 with HTTPS. Uses SHA-256 with RSA encryption. Chrome version 72 (64 bit) fails with ‘bad format’ error and may need to use an older release (ERR_SSL_SERVER_CERT_BAD_FORMAT).
Here is a python script which will backup the running-config of multiple ERS switches listed in a text file. This script will send Ctrl + Y code sequence to the switch and run the copy command to a local TFTP server.
Python file sshclientcfg.py:
import paramiko
import time
import getpass
username = raw_input(‘Enter your username: ‘)
password = getpass.getpass()
f = open (‘myswitches.txt’)
for line in f:
ip_address = line.strip()
ssh_client = paramiko.SSHClient()
ssh_client.set_missing_host_key_policy(paramiko.AutoAddPolicy())
ssh_client.connect(hostname=ip_address,username=username,password=password)
print ‘Successful connection’, ip_address
remote_connection = ssh_client.invoke_shell()
remote_connection.send(“\x19”)
print ‘Collecting running-config of ‘ + ip_address
remote_connection.send(‘copy running-config tftp address 192.168.1.100 filename ‘ + ip_address + ‘.asc\n’)
time.sleep(20)
readoutput = remote_connection.recv(655350)
saveoutput = open(‘Log file of ‘ + ip_address, ‘w’)
print ‘Saving to file called Log file of ‘ + ip_address + ‘\n’
saveoutput.write(readoutput)
saveoutput.write(‘\n’)
saveoutput.close
ssh_client.close()
Text file Myswitches.txt:
192.168.1.5
192.168.1.4
Output of script:
$ python sshclientcfg.py
Enter your username: admin
Password:
Successful connection 192.168.1.5
Collecting running-config of 192.168.1.5
Saving to file called Log file of 192.168.1.5
Successful connection 192.168.1.4
Collecting running-config of 192.168.1.4
Saving to file called Log file of 192.168.1.4
Note: The log file captured with the IP of the switch shows the output from the session which is useful to verify if it worked as expected or there was an error. The running-config file generated by the switch will be sent to the TFTP server so look there for the ASCII file.
The line below is used to provide Ctrl + Y response if prompted.
remote_connection.send(“\x19”)
ERS 4850 and VSP 7024
Save binary and ASCII configurations on ERS 4850 and VSP 7024:
copy config tftp address x.x.x.x filename ERS4850_name.bin
copy running tftp address x.x.x.x filename ERS4850_name.asc
copy config tftp address x.x.x.x filename VSP7024_name.bin
copy running tftp address x.x.x.x filename VSP7024_name.asc
VSP 4850 and VSP 7254
Save ASCII configurations on VSP 4850 and VSP 7254:
copy /intflash/config.cfg /intflash/config.yymmdd
copy /intflash/config.cfg x.x.x.x:VSP4850_name.yymmdd
Where x.x.x.x is IP address of TFTP server.
qos if-group name Trusted class trusted
qos if-group name Unrestricted class unrestricted
qos action 253 name baseAct253 update-dscp 46 update-1p 6
qos l2-element 253 name l2Clfr405 vlan-min 253 vlan-max 253 ethertype 0x800
qos classifier 253 set-id 253 name clfrComp253 element-type l2 element-id 253
qos if-assign port 1/1-23 name Unrestricted
qos if-assign port 1/24 name Trusted
qos if-assign port 2/ALL name Unrestricted
qos policy 253 name policy253 if-group Unrestricted clfr-type classifier clfr-id 253 in-profile-action 253 precedence 1